Standalone application

  • Main menu of standalone application should has options: File, Edit, Help.
  • File submenu has options: New…, Open…, Close, Save, Save As…, Exit.
  • Edit submenu has options: Undo, Redo
  • Help submenu has an option About.
  • After clicking File > New… option, a ‘New file dialog’ should appear. User has to choose a name for the new file and select folder where the file should be saved. Unlike to ecFeed installed as plugin in Eclipse IDE, the new file need not to be located in Eclipse project – it can be created in any folder.
  • Clicking the OK button should create an empty ect file in selected location and open and Ect document viewer window.
  • In order to close current Ect document, select File > Close option from the main menu.
  • To open an Ect document, select File > Open option from the main menu. Select directory and file name and click Ok.
  • Selecting an already opened file in File open dialog should ignore open operation – only the “opened” document should be displayed.
  • Many Ect files may be opened at the same time.
  • Modifications of Ect model are the same as described for EcFeed plugin of Eclipse IDE.
  • Nodes of the model have no implementation status.
  • There are no options: Implement and Go to implementation in context menu of nodes.
  • There are no Implement and Go to implementation buttons on property pages of the root node, class, method etc.
  • There are no Test online buttons on method’s property pages.
  • There is no button: Execute selected in the Test cases page of the method.
  • There are no comments sections on any level of Ect tree.
  • After opening the file, when no operations have been performed, the Edit > Undo and Edit > Redo options should be grayed.
  • After performing some operations Undo option should be accesible.
  • Redo option should be accessible when some Undo actions were performed.
  • Switching between document windows should also change accordingly the actions performed under Undo/Redo.